Email sending subsystem degradation, due to DDoS attack on Mailgun service
Incident Report for Welkin Health
Resolved
No degradation in email sending and delivery was observed during the monitoring period.
Posted Feb 12, 2024 - 15:06 PST
Update
Mailgun cloud provider is working through internal escalation process to help them with the mitigation, meanwhile they are working on scaling up the infrastructure to support the load.
Posted Feb 12, 2024 - 12:45 PST
Update
Await confirmation of results from Mailgun, after fix
Posted Feb 12, 2024 - 09:01 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2024 - 06:53 PST
This incident affected: Welkin API.