Twilo Incident - SMS, MMS and Verify API Delivery Delays to Carriers
Incident Report for Welkin Health
Resolved
Dear Welkin Customers,

We have received an update from Twilio:

They are no longer experiencing delivery delays for SMS, MMS and Verify API messaging to and from AT&T end user subscribers. This incident has been resolved.

Thank you for your patience
-Welkin Support-
Posted Feb 22, 2024 - 16:56 PST
Update
Dear Welkin Customers,

Twilio has provided an update:

They are still observing a recovery in delivery ratios levels for SMS, MMS and Verify API messaging to and from AT&T end user subscribers. They will continue monitoring the service to ensure a full recovery. They will provide another update in 2 hours or as soon as more information becomes available.

We will relay this information to our customers once information is available.

Thank you for your patience
-Welkin Support-
Posted Feb 22, 2024 - 14:51 PST
Monitoring
Dear Welkin Customers,

Twilio has reported - SMS, MMS and Verify API Delivery Delays to AT&T USA.

They are observing delivery ratios nearing normal levels for SMS, MMS and Verify API messaging to and from AT&T end user subscribers. They remain in close communication with AT&T as they continue to manage recovery through careful load balancing and capacity management to ensure smooth recovery. They will provide another update in 2 hours, or as soon as more information becomes available.

We will continue to keep our endusers updates on status as it becomes available.

Thank you for your continued patience.
-Welkin Support-
Posted Feb 22, 2024 - 10:51 PST
This incident affected: Welkin Platform (Care, Designer, Admin) and Welkin API.