Full Access for all users to Welkin to Care/Designer/Admin
Incident Report for Welkin Health
Resolved
We have confirmed full access to the Welkin system at this time.
Posted Dec 12, 2024 - 22:18 PST
Update
We are continuing to investigate this issue.
Posted Dec 12, 2024 - 22:13 PST
Investigating
We are investigating increased authentication errors
Posted Dec 12, 2024 - 19:03 PST
This incident affected: Welkin Platform (Care, Designer, Admin).