Paubox vendor having technical issues related to secure email transmissions
Incident Report for Welkin Health
Resolved
The issue has been resolved.
Posted Oct 24, 2023 - 14:15 PDT
Investigating
Dear Welkin Customers,

We wish to inform you that our secure email vendor, Paubox, is currently experiencing technical difficulties which are causing secure emails sent from Welkin to be held in a pending status. Paubox is fully aware of the issue and their engineering team is actively working towards resolving it.

We apologize for any inconvenience this may cause and will keep you updated on the progress towards a resolution.

Thank you for your understanding and patience.
Posted Oct 24, 2023 - 13:14 PDT