Welkin Platform Service Disruptions
Incident Report for Welkin Health
Resolved
Dear Welkin Valued Customers,

The platform's ongoing issues have been resolved. Please feel free to try logging into the system now.

If you have any urgent concerns or need immediate assistance, please do not hesitate to contact our support team. We are here to help and will do our best to address your needs as soon as possible.

Thank you for your continued partnership

-Welkin Team-
Posted Jul 31, 2023 - 13:04 PDT
Identified
Dear Welkin Valued Customers,

The Welkin platform is continuing to experience ongoing issue. Our engineering team is actively working to resolve it.

We will provide a status update once we have one available.

Thank you for your continued patience and understanding.
-Welkin Team-
Posted Jul 31, 2023 - 12:10 PDT
Monitoring
Dear Welkin Valued Customers,

The system has been stabilized. You may now proceed to log in. The engineering team will continue to monitor the situation.

Thank you for your continued trust and support

-Welkin Team-
Posted Jul 31, 2023 - 09:28 PDT
Identified
Dear Welkin Valued Customers,
Welkin is currently facing a technical issue. The engineering team is aware of the problem and actively working on resolving it.

We will keep everyone updated as we progress through the investigation.

If you have any urgent concerns or need immediate assistance, please do not hesitate to contact our support team. We are here to help and will do our best to address your needs as soon as possible.



Thank you for your continued trust and support

-Welkin Team-
Posted Jul 31, 2023 - 08:26 PDT
This incident affected: Welkin Platform (Care, Designer, Admin) and Welkin API.