Messaging issues with Twilio: SMS Delivery Delays to Cingular Wireless (AT&T) in the US

Incident Report for Welkin Health

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 02:48 PDT

Update

Dear Customers,

We want to make you aware of two ongoing incidents reported by Twilio, our communications provider, which may impact services on the Welkin platform:
1. SMS Delivery Delays to AT&T (Cingular Wireless, US):
Twilio is experiencing delays delivering SMS messages to AT&T users in the US. This may affect inbound & outbound SMS sent via Welkin.
Incident Details: https://status.twilio.com/incidents/16l0gp03xh0t

2. Potential Connectivity Issues with Live Chat:
Twilio has also reported a separate incident that may affect chat and messaging connectivity. As Welkin’s chat functionality relies on Twilio, you or your clients may notice degraded performance.
Chat Incident: https://status.twilio.com/incidents/kcytb2vzwc82

Twilio engineers are actively working on both issues. We are monitoring the situation closely and will keep you informed of any relevant changes.

Thank you for your understanding. Please reach out to our support team if you have questions or encounter issues.

Best regards,
The Welkin Team
Posted Jun 12, 2025 - 12:55 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 12:39 PDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 12:36 PDT

Investigating

Dear Customers,

We want to inform you that Twilio is currently experiencing SMS delivery delays when sending messages to Cingular Wireless (AT&T) in the US. This may impact some of the messages sent via our platform.

Twilio’s engineering team is actively working with their carrier partner to resolve the issue. We are monitoring the situation closely and will provide updates as they become available.

You can follow the latest updates directly on Twilio’s status page:
Twilio Incident Details: https://status.twilio.com/incidents/16l0gp03xh0t
Twilio Status Page: https://status.twilio.com/

We appreciate your patience and understanding. If you or your clients are affected and need assistance, please don’t hesitate to reach out.

Thank you,
The Welkin Team
Posted Jun 12, 2025 - 12:34 PDT
This incident affected: Twilio SMS and Twilio PROGRAMMABLE CHAT.